3

I’m not able to use any functions that require JavaScript on (meta.)anime.stackexchange.com, i.e.: I can’t vote, can’t comment, the SE notification bar at the top doesn’t work, no hover pop-ups for users/tags, etc.

It works for all other Stack Exchange sites I use.

I tried it with a different Firefox profile, tried it as guest, cleared cache etc. When I logout and try to vote up a question, nothing happens. If I try this on any other SE site, I get the Thanks for the feedback! pop-up, asking me to login.

In Chromium everything seems to work fine.

I’m using an older Firefox version (20.x) currently (can’t test it with the current version atm). If this should be the reason for the broken JS, then why is this not the case for all other SE sites? Tested it with the current version (23.0.1) on a different OS: same problem there, too.

EDIT: Updates

  • In the error console, I get the following error when reloading the page:

    TypeError: localStorage is null
    Source: http://sstatic.net/js/third-party/japanese-l-u.js?v=2
    Line: 32

  • I have the very same problem with japanese.stackexchange.com also: no voting etc. possible in Firefox
  • Thanks to the error message about localStorage, I now know what’s causing this bug: the about:config setting dom.storage.enabled = false (it needs to be true if you want to use any JS functions here)

  • Have you tried clearing your cache? – Madara Uchiha Sep 8 '13 at 16:46
  • 2
    @unor If you bring up the developer console, so you get see any errors? – кяαzєя Sep 8 '13 at 19:05
  • 1
    Suggestion - check out japanese.stackexchange.com and see if there are any problems there. If so, it could be something to do with the Japanese-language add-ons that are (I think) unique to here and Japanese.SE. – senshin Sep 9 '13 at 21:54
  • @Krazer: Got one error (see question edit). – unor Sep 10 '13 at 8:49
  • @senshin: You are right, same problem with japanese.stackexchange.com. – unor Sep 10 '13 at 8:49
  • @MadaraUchiha: Yes, clearing cache was one of the first things I tried. I also used another, fresh Firefox profile. – unor Sep 10 '13 at 8:50
  • 1
    Thank you, we'll pass it upwards. – Madara Uchiha Sep 10 '13 at 8:51
  • 1
    This is only for sites that use the JS Japanese language helpers, we're looking into it now. – Tim Post Sep 10 '13 at 15:50
5

We only support the last two releases for FF, which is 22 and 23. However, while we don't guarantee it, older versions usually work.

In this case, it's probably something to do with the Hiragana support which is also enabled on Japanese SE - and we can't fix that for unsupported browsers. The best thing to do is just upgrade FF, if you don't want to do that, try a more recent version of another browser.

Still, at least for the time being, the version you're using will probably work on other sites, at least where Hiragana (and possibly MathJax) aren't loaded.

For reference, here's our list of supported browsers.

Edit

Reproduced by disabling local storage on FF - escalating to the devs.

This was in fact an issue in the Japanese support user script, which uses local storage to store preferences and does not deal with it being disabled, causing JS to break entirely - even on current browsers. As we strongly recommend but don't require local storage to be enabled, a fix has been pushed that will go out in the next build.

  • Same problem with the current version (23.0.1). See my edit in the question for the cause of this bug. – unor Sep 10 '13 at 15:35
  • Seems to be due to local storage then - going to check into this further as its absence should not completely break JS – Tim Post Sep 10 '13 at 15:43
  • Thanks! It works now :) – unor Sep 13 '13 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .